Nadawanie nazw komórkom i grupom komórek

W sytuacji gdy masz do czynienia z duża ilością komórek, możliwość nadawania nazw komórkom i grupom komórek może okazać się bardzo przydatna, ponieważ łatwiej jest zrozumieć zapis „=SUMA(koszt)/miesiąc”niż „=SUMA(B3:B14)/D5”.

Spójrz na poniższą tabelę. Znajdują się w niej imiona trzech osób oraz ilość godzin jakie oni przepracowali każdego dnia tygodnia.

Nadawanie nazwy komórkom

Załóżmy, że chcesz mieć możliwość osobnego wyboru wszystkich godzin jakie przepracowali mężczyźni, bez konieczności każdorazowego ich zaznaczania.

Przykład 1:

Zaznacz zatem komórki od C3 do G3, a następnie trzymając cały czas wciśnięty klawisz Ctrl, dodatkowo zaznacz komórki od C5 do G5. Po zaznaczeniu komórek wpisz w polu nazwy słowo „Mężczyźni”.

W naszym przykładzie mamy jedną kobietę. Zaznacz komórki od C4 do G4 i tym razem w polu nazwy wpisz „Kobieta”.

Automatyczne zaznaczanie wielu grup komórek

Załóżmy, że chcesz zaznaczyć godziny pracy dla każdego dnia z osobna. Możesz to zrobić w podobny sposób, jak zrobiłeś to dla „Mężczyzn” i „Kobiety”. W tym przypadku trzeba by było zrobić pięć zaznaczeń dla każdego dnia z osobna. Aby jednak przyśpieszyć pracę stworzymy pięć zaznaczeń za jednym razem.

Zaznacz komórki od C2 do G5, a następnie przejdź do FORMUŁY >> Nazwy zdefiniowane >> Utwórz z zaznaczenia. Pojawi się okno z pytaniem o to, których komórek użyć jako nazw. W naszym przypadku będą to komórki z górnego wiersza.

Kliknij OK, a następnie strzałkę znajdującą się przy polu nazwy. Znajduje się tutaj zarówno grupa „Mężczyźni”, jak również grupy dla poszczególnych dni tygodnia.

Wybór grup komórek

Istnieje kilka sposobów na wybór wcześniej stworzonych grup.

Przykład 2:

Pierwsza z metod polega na wpisaniu nazwy grupy bezpośrednio do komórki. Oczywiście jeżeli wpiszesz nazwę „=Mężczyźni”, to Excel zwróci błąd, ponieważ nie możesz wpisać do jednej komórki wielu komórek. W tym wypadku możesz jej użyć w funkcji.

W tym przykładzie użyj funkcji SUMA do obliczenia sumy godzin, jaką przepracowali mężczyźni. Kiedy zaczniesz wpisywać formułę i dojdziesz do „=SUMA(Mę”, to Excel wyświetli podpowiedź.

Aby zaakceptować tę grupę użyj przycisku Tab lub kliknij na nią.

Przykład 3:

Drugim sposobem jest wybranie grupy z FORMUŁY >> Nazwy zdefiniowane >> Użyj w formule.

Przykład 4:

Trzecia metoda to Wklejanie nazwy. Naciśnij klawisz F3. W oknie które się pojawiło wybierz grupę z listy.

UWAGA

Jeżeli przeniesiesz wszystkie komórki znajdujące się w danej grupie to Excel zapamięta ich nową pozycję. Jeżeli natomiast przeniesiesz tylko ich część, Excel nie będzie wstanie odpowiednio ich zaznaczyć.

Menadżer nazw

W menedżerze nazw możesz zarządzać grupami. Możesz je tu dodawać, usuwać lub edytować.

Znajdziesz go w FORMUŁY >> Nazwy zdefiniowane >> Menadżer nazw lub używając skrótu klawiszowego Ctrl + F3.

Skillshare’s usually $10 a month, but because you’re an OfficeTuts reader you can get your first month free by clicking here. That’s unlimited access to over 18,000 classes on Excel, VBA, and much more.